强制依赖

1
yum install -y which sed make binutils gcc g++ gcc-c++ bash patch gzip bzip2 perl tar cpio unzip rsync file bc wget

可选依赖

1
yum install -y python2 python38 ncurses5 qt5 glib2 git scp asciidoc w3m dblatex graphviz python-matplotlib

常见错误:

1
2
3
4
5
6
7
[root@localhost buildroot-2020.08-rc1]# make
Your Perl installation is not complete enough; at least the following
modules are missing:

Thread::Queue

make: *** [dependencies] 错误 1

解决:

1
yum install -y perl-Thread-Queue
1
checking whether mknod can create fifo without root privileges... configure: error: in `/opt/buildroot-2020.08-rc1/output/build/host-tar-1.29':

解决:不使用root账户